Slow Response Times
Incident Report for TelePharm
Resolved
The issue has been resolved and speeds are getting back to normal.
Posted Jul 10, 2017 - 11:55 CDT
Identified
We've identified an issue causing slow response times for a sub-set of users. A fix is underway.
Posted Jul 10, 2017 - 11:40 CDT