Slow Response Times

Incident Report for TelePharm

Resolved

Service has been fully restored.
Posted Jul 10, 2017 - 13:21 CDT

Investigating

Response times have gone back up but certain users are still experiencing some loading issues. We are investigating.
Posted Jul 10, 2017 - 12:30 CDT