Medispan service issues
Incident Report for TelePharm
Resolved
The Medispan service has been restored.
Posted Dec 01, 2016 - 13:15 CST
Investigating
We are investigating an issue with our Medispan service. Some users may notice issues loading DUR and medication information.
Posted Dec 01, 2016 - 13:00 CST