Page loading issue
Incident Report for TelePharm
Resolved
Medispan stock images have been restored.
Posted Aug 04, 2022 - 09:05 CDT
Identified
On August 3, 2022 we identified an issue that will cause some items such as Medispan stock images to be temporarily unavailable in TelePharm. Technicians will also not hear an audible notification when a prescription is approved. These items are being restored as soon as possible.
Posted Aug 03, 2022 - 21:58 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 03, 2022 - 15:26 CDT
Investigating
A small group of users is reporting page loading issues. We are investigating the issue.
Posted Aug 03, 2022 - 14:51 CDT
This incident affected: TelePharm - Application.