TelePharm Unavailable
Incident Report for TelePharm
Resolved
The TelePharm application is fully operational.
Posted Dec 14, 2017 - 16:36 CST
Monitoring
Our service provider has restored access to the TelePharm application.
Posted Dec 14, 2017 - 16:02 CST
Identified
We have identified the issue and are working to restore availability
Posted Dec 14, 2017 - 14:57 CST
Investigating
Many customers are experiencing slowness and inaccessibility of the TelePharm application. We are investigating.
Posted Dec 14, 2017 - 14:48 CST