long load times detected

Incident Report for TelePharm

Resolved

Performance of the service has been restored
Posted Jun 09, 2021 - 13:32 CDT

Monitoring

A fix has been implemented and we are monitoring the situation.
Posted Jun 09, 2021 - 11:54 CDT

Identified

We have identified the issue.
Posted Jun 09, 2021 - 11:43 CDT

Investigating

We are currently investigating the issue.
Posted Jun 09, 2021 - 11:41 CDT
This incident affected: TelePharm - Application.