Continuous loading when logging into app.telepharm.io
Incident Report for TelePharm
Resolved
The issue preventing users to login has been resolved.
Posted Jul 14, 2016 - 08:35 CDT
Identified
Certain users are experiencing an issue when trying to login to app.telepharm.io. The issue has been identified and resolution is underway.
Posted Jul 14, 2016 - 08:31 CDT