Trouble loading pages
Incident Report for TelePharm
Resolved
This incident has been resolved.
Posted Aug 11, 2017 - 11:16 CDT
Monitoring
Things are returning to normal. We are continuing to monitor the situation.
Posted Aug 11, 2017 - 09:55 CDT
Investigating
Certain users are experiencing trouble logging in or accessing their Dashboard.
Posted Aug 11, 2017 - 09:36 CDT