Increased Error Rates

Incident Report for TelePharm

Resolved

The issue has been resolved.
Posted Sep 05, 2017 - 12:36 CDT

Identified

The issue has been identified and a fix is in progress.
Posted Sep 05, 2017 - 12:27 CDT

Investigating

We are investigating higher than usual error rates. Some users may experience trouble loading.
Posted Sep 05, 2017 - 12:19 CDT