Intermittent Failures
Incident Report for TelePharm
Resolved
This incident has been resolved.
Posted Sep 20, 2017 - 11:28 CDT
Investigating
AWS appears to be working through some issues causing certain regions to experience DNS errors when loading pages.
Posted Sep 20, 2017 - 09:06 CDT