Medispan Images and DURs Not Loading
Incident Report for TelePharm
Resolved
Medi-Span images and DUR information is now fully available.
Posted Apr 17, 2023 - 11:43 CDT
Investigating
We are experiencing issues displaying Medispan images and DUR information. We are actively researching this issue.
Posted Apr 17, 2023 - 11:14 CDT
This incident affected: TelePharm - Application.