Degraded application performance
Incident Report for TelePharm
Resolved
The incident has been resolved and all systems should return to normal.
Posted Dec 07, 2023 - 17:41 CST
Identified
The issue has been identified and is related to a service provided by an upstream provider. They are working to resolve the issue now.
Posted Dec 07, 2023 - 17:29 CST
Investigating
We are currently investigating an issue related to the pill counting feature.
Posted Dec 07, 2023 - 17:08 CST
This incident affected: TelePharm - Application.