Trouble logging into app.telepharm.io
Incident Report for TelePharm
Resolved
Services have been restored back to normal.
Posted May 14, 2016 - 11:13 CDT
Identified
An issue has been identified that could be preventing certain users from accessing app.telepharm.io.
Posted May 14, 2016 - 11:02 CDT