TelePharm Application Performance Degraded
Incident Report for TelePharm
Resolved
The fix has been issued and the TelePharm application is fully operational.
Posted Oct 10, 2018 - 07:37 CDT
Update
We have identified the issue and are releasing a fix.
Posted Oct 10, 2018 - 07:22 CDT
Investigating
The TelePharm web application is experiencing performance issues and is unresponsive for some users
Posted Oct 10, 2018 - 07:11 CDT
This incident affected: TelePharm - Application.