Login and load issue
Incident Report for TelePharm
Resolved
This issue has been resolved.
Posted Mar 20, 2018 - 10:57 CDT
Investigating
Some pages are failing to load for a subset of users. We are investigating.
Posted Mar 20, 2018 - 10:18 CDT